CodeIgniter 2.0 goes bye bye PHP4

Započeo holodoc, 19.11.2010, 00:00

« prethodna tema - sledeća tema »
Idi dole

holodoc


CodeIgniter 2.0
Za sve koji koriste ovaj sjajan PHP framework odlična vest... CodeIgniter 2.0 koji treba uskoro da zvanično ugleda svetlost dana potpuno je batalio podršku za PHP 4 i uklonio abstrakciju u svom modelu koji je do sada vodio računa o PHP4, što je uzrokovalo nepotrebnim gubitkom performanse za sve one koji su i onako koristili PHP 5 :)

Minimum koji je sada neophodan za pravilno funkcionisanje je PHP 5.1.6 (zbog CentOS-a i Red Hat derivata) a detalje o novoj verziji možete da nađete na sledećoj stranici http://codeigniter.com/news/codeigniter_2.0_-_now_with_more_awesome/

Kod koji se još uvek nalazi u beta fazi je moguće preuzeti direktno iz repoa (potreban neki Mercurial klijent) a može i direktno kroz bitbucket (http://bitbucket.org/ellislab/codeigniter).
<?php
abstract class Ignorance extends Stupidity implements Unavoidable 
    private function 
__construct(){
        
parent::__destruct();
    }; 

// EOF -> life.php

Idi gore